incubator-ivy-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin (JIRA)" <j...@apache.org>
Subject [jira] Created: (IVY-507) Bug on handling dependency artifacts when a dependency configuration is specified
Date Mon, 14 May 2007 09:30:16 GMT
Bug on handling dependency artifacts when a dependency configuration is specified
---------------------------------------------------------------------------------

                 Key: IVY-507
                 URL: https://issues.apache.org/jira/browse/IVY-507
             Project: Ivy
          Issue Type: Bug
    Affects Versions: 2.0.0-alpha-1
            Reporter: Xavier Hanin
             Fix For: 2.0.0-alpha-2


When you declare a dependency on a module using the dependency artifact construct, Ivy fails
to resolve it if you specify also a dependency module configuration. All our unit tests on
this subject only test without dependency module configurations, thus defaulting to *.

Working example:
	    <dependency org="apache" name="slide" rev="20050629.161100" conf="webdav->*">
  
	      	<artifact name="slide-webdavlib" type="jar"/> 
	    </dependency>
Buggy example:
	    <dependency org="apache" name="slide" rev="20050629.161100" conf="webdav->default">
  
	      	<artifact name="slide-webdavlib" type="jar"/> 
	    </dependency>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message