incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aviem Zur <aviem...@gmail.com>
Subject Re: [VOTE] Release Apache Liminal (incubating) 0.0.2rc1-INCUBATING
Date Wed, 21 Apr 2021 09:19:43 GMT
We declare exactly 9 dependencies in our requirements.txt
<https://github.com/apache/incubator-liminal/blob/0.0.2rc1-INCUBATING/requirements.txt>

docker==4.2.0
apache-airflow==1.10.12
click==7.1.1
Flask==1.1.1
pyyaml==5.3.1
boto3==1.12.10
botocore==1.15.21
kubernetes==12.0.1
wheel==0.36.2


pipdeptree --reverse --packages chardet
------------------------------------------------------------------------
chardet==3.0.4
  - requests==2.24.0 [requires: chardet>=3.0.2,<4]
    - apache-airflow==1.10.12 [requires: requests>=2.20.0,<3]
    - docker==4.2.0 [requires: requests>=2.14.2,!=2.18.0]
      - moto==1.3.14 [requires: docker>=2.5.1]
    - kubernetes==12.0.1 [requires: requests]
    - moto==1.3.14 [requires: requests>=2.5]
    - requests-oauthlib==1.3.0 [requires: requests>=2.0.0]
      - kubernetes==12.0.1 [requires: requests-oauthlib]
    - requests-toolbelt==0.9.1 [requires: requests>=2.0.1,<3.0.0]
      - twine==3.3.0 [requires: requests-toolbelt>=0.8.0,!=0.9.0]
    - responses==0.12.1 [requires: requests>=2.0]
      - moto==1.3.14 [requires: responses>=0.9.0]
    - Sphinx==3.5.1 [requires: requests>=2.5.0]
      - recommonmark==0.7.1 [requires: sphinx>=1.3.1]
      - sphinx-autobuild==2020.9.1 [requires: sphinx]
    - twine==3.3.0 [requires: requests>=2.20]

As we can see above, many of the main packages we use require `requests`
which requires `chardet`

For example: airflow, docker, kubernetes, moto, sphinx all require
`requests` package which requires `chardet` package

Please advise,
Thanks,
Aviem


On Wed, Apr 21, 2021 at 8:22 AM Jean-Baptiste Onofre <jb@nanthrax.net>
wrote:

> Hi Justin,
>
> I agree, with an updated DISCLAIMER, I guess we can move forward with
> 0.0.2 release.
>
> However, we have to double check that chardet is not a "direct" dependency
> (it seems to come from Airflow, but I didn’t actually check yet).
>
> Regards
> JB
>
> > Le 21 avr. 2021 à 00:15, Justin Mclean <justin@classsoftware.com> a
> écrit :
> >
> > Hi,
> >
> >> And that’s my point: chardet is not a direct Liminal dependency, but
> actually an Airflow dependency.
> >>
> >> So, I think that’s either Liminal can release "as it is" or Airflow
> should address this dependency.
> >
> > If you had a WIP-DISCLAIMER and listed this issue in it you could make a
> release.
> >
> > I wold contact Airflow and have a chat to them and see why it needed.
> >
> > BTW I’m not 100% sure it is an Airflow dependancy, but I’m not 100%
> familiar with how python pip tools work.
> >
> > pipdeptree for me gives:
> >
> > pipreqs==0.4.10
> >  - docopt [required: Any, installed: 0.6.2]
> >  - yarg [required: Any, installed: 0.1.9]
> >    - requests [required: Any, installed: 2.25.1]
> >      - certifi [required: >=2017.4.17, installed: 2020.4.5.1]
> >      - chardet [required: >=3.0.2,<5, installed: 4.0.0]
> >      - idna [required: >=2.5,<3, installed: 2.10]
> >      - urllib3 [required: >=1.21.1,<1.27, installed: 1.26.2]
> >
> > pipdeptree --reverse --packages chardet gives:
> >
> > chardet==4.0.0
> >  - requests==2.25.1 [requires: chardet>=3.0.2,<5]
> >    - yarg==0.1.9 [requires: requests]
> >      - pipreqs==0.4.10 [requires: yarg]
> >
> > Which is different to what you have.
> >
> > Pipregs is just for producing requirements.txt right? So it may not be a
> runtime dependancy and be considered optional?
> >
> > From  running  pip-licenses Yargs is MIT, requests is ALv2 and chardet
> is LGPLv2.
> >
> > Thanks,
> > Justin
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
> > For additional commands, e-mail: general-help@incubator.apache.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
> For additional commands, e-mail: general-help@incubator.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message