incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Friedrich -X (efriedri - TRITON UK BIDCO LIMITED c/o Alter Domus (UK) Limited -OBO at Cisco)" <>
Subject Re: [VOTE] Apache Toree 0.3.0-incubating (RC1)
Date Mon, 12 Nov 2018 20:39:48 GMT
Hey Luciano-
  I ran ‘vagrant up’ and tried to build using the VM that the vagrant file created for
me. You might want to make a note in your README or modify the Vagrantfile to install the
proper version of Scala.


On Nov 12, 2018, at 2:09 PM, Luciano Resende <<>>

On Fri, Nov 9, 2018 at 12:32 PM Eric Friedrich -X (efriedri - TRITON
UK BIDCO LIMITED c/o Alter Domus (UK) Limited -OBO at Cisco)
<<>> wrote:

 A few notes on the release package. Structure and contents look fine, but I’ve included
some suggestions on some of the supporting things

Git tag not signed. I dont think this is a hard requirement but is good practice
$ git tag -v v0.3.0-incubating-rc1
error: v0.3.0-incubating-rc1: cannot verify a non-tag object of type commit.

Commit is empty in dist/toree/VERSION (but is correct in the binary release)
$ cat dist/toree/VERSION
VERSION: 0.3.0-incubating

Was not able to build from source using Vagrant, perhaps something is wrong with my environment.
$ vagrant up
$ export USE_VAGRANT=true
$ make
Getting Scala 2.12.6 (for sbt)...
:: retrieving :: org.scala-sbt#boot-scala
       confs: [default]
       5 artifacts copied, 0 already retrieved (19632kB/72ms)
java.lang.UnsupportedClassVersionError: scala/Option : Unsupported major.minor version 52.0

I checked:
- sigs and hashes good
- Licenses present and correct
- NOTICE file present
- No binary files


Thanks Eric, we will take a look at your issues/suggestions. As for
Scala 2.12, that is not supported for Toree yet.

Luciano Resende

To unsubscribe, e-mail:<>
For additional commands, e-mail:<>

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message