1.1-groovy-2.4 is what I've been including, but I got this error while testing the installation

org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed:
Could not instantiate global transform class org.spockframework.compiler.SpockTransform specified at jar:file:/C:/Program%20Files%20(x86)/Groovy/Groovy-3.0.0/lib/spock-core-1.1-groovy-2.4.jar!/META-INF/services/org.codehaus.groovy.transform.ASTTransformation  because of exception org.spockframework.util.IncompatibleGroovyVersionException: The Spock compiler plugin cannot execute because Spock 1.1.0-groovy-2.4 is not compatible with Groovy 3.0.0-alpha-1. For more information, see http://versioninfo.spockframework.org
Spock artifact: file:/C:/Program%20Files%20(x86)/Groovy/Groovy-3.0.0/lib/spock-core-1.1-groovy-2.4.jar
Groovy artifact: file:/C:/Program%20Files%20(x86)/Groovy/Groovy-3.0.0/lib/groovy-3.0.0-alpha-1.jar

The latest (20171211.142320-34) 1.2 snapshot does seem to work though.  I guess I'll repackage 3.0 with it.

-Keegan

On Wed, Dec 20, 2017 at 3:29 AM, Russel Winder <russel@winder.org.uk> wrote:
On Wed, 2017-12-20 at 15:56 +1000, Paul King wrote:
> You can use a SNAPSHOT version of Spock, e.g. 1.1-groovy-2.4-SNAPSHOT
> or
> 1.2-groovy-2.4-SNAPSHOT

1.1-groovy-2.4 is released, no need to use a snapshot.

1.2-groovy-2.4-SNAPSHOT doesn't seem to have made it to Maven Central
yet.

--
Russel.
===========================================
Dr Russel Winder      t: +44 20 7585 2200
41 Buckmaster Road    m: +44 7770 465 077
London SW11 1EN, UK   w: www.russel.org.uk