Dear all,
I have learned to deploy Hadoop 2.10.0 + Flume 19.0 + ElasticSearch 1.7.6 to demo a context:
nginx log ====> Hadoop & ElasticSearch.

I found the Flume 19.0 works with library Elastic Search 1.7.6.
Now I want to run with ElasticSearch 7.6.2 but I faced this problem:

java.lang.IllegalStateException: Received message from unsupported version: [1.0.0] minimal compatible version is: [6.8.0]

I'm analyzing this root cause from the old library flume client (file flume-ng-elasticsearch-sink-1.9.0.jar) sending a message with version 1.0.0. While the new version ElasticSearch 7.6.2 support message with version 6.8.0.

Can you help me to run Flume with new version of ElasticSearch?

Thach