flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Parag Hukeri <paraghuk...@yahoo.com>
Subject Re: ExecSource tail -F stops after a while
Date Sat, 03 Nov 2012 00:21:32 GMT
I tried to use the FileChannel; but am getting an exception -
org.apache.flume.FlumeException: Unable to load channel type: file, class: org.apache.flume.channel.file.FileChannel
Caused by: java.lang.ClassNotFoundException: org.apache.flume.channel.file.FileChannel
I am using  apache-flume-1.2.0. What version of flume is needed for FileChannel?

--- On Fri, 11/2/12, Josh West <jsw@one.com> wrote:

From: Josh West <jsw@one.com>
Subject: Re: ExecSource tail -F stops after a while
To: user@flume.apache.org
Date: Friday, November 2, 2012, 1:48 PM

This happened to me consistently when buffering tail -F contents into the Memory Channel. 
Try switching to the File Channel.  This solved the issue for me.

On 11/02/2012 07:15 PM, Parag Hukeri wrote:

I am using apache-flume-1.2.0. I have set up an ExecSource that tails a log file & gets
the entries from this log file. The log file size is approx 4 GB (approx 12 million lines
written over a period of 12 hrs). As the process starts everything seems to work fine for
approx 9.5 hrs. (approx 9.5 million lines of log data is successfully retrieved by ExecSource).
It then stops reading the output from tail. I don't see any exceptions being thrown. I don't
think the problem is with the actual tail command. I was able to successfully manually tail
the log file & all 12 million records were retrieved by tail. Running on a Linux system.
Not sure what the issue might be with ExecSource? Any help would be appreciated. Thanks.
Josh West
Lead Systems Administrator
One.com, jsw@one.com
View raw message