celix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [celix] unitink72 opened a new issue #283: etcd client watch API not consistently working
Date Wed, 09 Sep 2020 14:26:49 GMT

unitink72 opened a new issue #283:
URL: https://github.com/apache/celix/issues/283


   I'm trying to run the example test, etcdlib_test that comes in the source repo.  The watch
API part does not run reliably.  Sometimes it works, sometimes the first watch API call works
then the second fails, sometimes it fails right away.  The first transaction to set a database
entry and then check its value always works fine.
   
   Some things I've tried:
   Changing wait times
   Creating a separate etcdlib_t within the pthread
   Spinning up the old version of etcd mentioned in the comments - 2.3.7
   Tried on two different machines - both Ubuntu, one with etcd in a docker container
   Adding lots of new printfs
   
   No matter what I tried, sometimes the call etcdlib_watch just hangs even though it shouldn't.
 The test in libs/etcdlib/test should duplicate my issue, but I'm also including my test which
adds some printf's to more clearly show the issue.
   
   [etcdlib_test.c.txt](https://github.com/apache/celix/files/5195832/etcdlib_test.c.txt)
   
   


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



Mime
View raw message