celix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Broekhuis <a.broekh...@gmail.com>
Subject Re: GTK usage & MacOS & cmake
Date Thu, 13 Oct 2011 07:54:02 GMT
Hi Frank,

2011/10/13 MULDER Frank Willem <frank.mulder@nl.thalesgroup.com>

> Hello,
>          In a message of 29 august 2011 to the Celix developer mailing
> list, I described a cmake problem under MacOS X.

At first I couldn't find the original message, but it was mailed on the 9th
of September ;).

> It concerned the linking phase of a Celix/GTK application by cmake.
> I recently heard that this problem was solved by a Celix developer.
> If this problem has been solved, can there be a follow-up of the mail of 29
> august 2011 in which the solution is explained?

To answer your question, there where some errors in your cmake file related
to the GTK variables.

You used <xx>_LINK_DIRS while the CMake FindPkgConfig file clearly states
that <xx>_LIBRARY_DIRS must be used for the link directories.

After this change the code compiles. During runtime there was an
uninitialized pointer somewhere which has to be set to NULL. I can't recall
where this was, but this can easily be found when running/debugging the

As a final remark, the example code has been checked in into SVN. You can
use the celix-commits mailing list to follow what is happening in SVN. The
code in SVN should work on a Mac for sure, Linux is tested less frequently.
Feel free to follow the changes and test what is going on.

It has been a while since I checked this code in, so if I forgot something
and these hints aren't enough, you can compare your original code with the
code from SVN.

Met vriendelijke groet,

Alexander Broekhuis

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message