ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Sicker <boa...@gmail.com>
Subject Re: Next plans for Ivy
Date Sat, 02 Nov 2019 19:32:23 GMT
Right, that’s true. The more JDKs you require in the build, the harder it
is to set up. If you target Java 8 but build at a newer release, you could
possibly get away with a single JDK plus an API checker to avoid using new
things.

On Fri, Nov 1, 2019 at 22:33 Jaikiran Pai <jaikiran@apache.org> wrote:

> Hello Matt,
>
> On 31/10/19 2:34 AM, Matt Sicker wrote:
> > Java 9 and beyond can be handled with version specific code in META-INF.
>
> I think we should be able to do that even now. Of course, _building_ Ivy
> would need higher version of Java (to use those specific APIs) but once
> built, we can package these higher version classes within the META-INF
> structure and that should get picked up if someone uses Ivy in a higher
> version of Java and at the same time shouldn't impact Java 8 usage.
>
> -Jaikiran
>
-- 
Matt Sicker <boards@gmail.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message