ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jaikiran Pai <jaiki...@apache.org>
Subject Recent build enhancements and CI jobs to help test Java runtime compatibility
Date Mon, 26 Aug 2019 11:58:14 GMT
A while back I mentioned[1] the issue we ran into with our Ant 1.10.6
release which broke compatibility with Java 8 runtime. I outlined what
needed to be done to be able to catch such issues going forward. In
short, we needed our build logic and our CI infrastructure to be able to
do the following:

- Our build should use the right javac attributes to compile the right
set of classes (some of which use Java 9+ APIs)
- Our CI infrastructure should have jobs which do:
    - Build (compile, jar, binary generation) using multiple different
Java versions, including the minimal supported Java version, and then
use the same Java version which was used to build Ant, to run tests
against that built version. We already had and will continue to have
such CI jobs[2]
    - Build (compile, jar, binary generation) using multiple different
Java versions, including the minimal supported Java version and then use
the minimal support Java version (Java 8) to run (only) tests against
that built Ant. This will cover the case where Ant is built with a
higher Java version and is being run in the minimal supported Java
runtime (which right now is Java 8).

To accomplish the above goals, this weekend I have been doing some minor
enhancements to the build infrastructure and also have introduced a
test-compatibility.sh[3] script which helps us to use a CI job to run
this Java runtime compatibility tests. A new job[4] has also been
created to use this script.

When I find some time I'll replicate that script to Windows OS too and
then have a CI job for Windows use this. All this should help us be a
bit more confident about our compatibility with different Java versions.


[1] https://www.mail-archive.com/dev@ant.apache.org/msg48001.html
[2] https://builds.apache.org/job/Ant-Build-Matrix-master-Linux/ and
https://builds.apache.org/job/Ant-Build-Matrix-master-Windows/
[3] https://github.com/apache/ant/blob/master/test-compatibility.sh
[4] https://builds.apache.org/job/Ant%20Master%20Compatibility%20Linux/

-Jaikiran


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message