ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jaikiran <...@git.apache.org>
Subject [GitHub] ant-ivy pull request #25: Upgrade to latest Ant release (non-Java 8 one)
Date Sun, 21 May 2017 14:01:54 GMT
GitHub user jaikiran opened a pull request:

    https://github.com/apache/ant-ivy/pull/25

    Upgrade to latest Ant release (non-Java 8 one)

    The commit here upgrades the Ant dependencies to the latest released ones.
    
    A few notes about the dependencies:
    
    - `org.apache.ant:ant-trax` dependency has been removed since it's no longer relevant
as per the Ant release notes here[1]
    >> ant-trax.jar is no longer produced since TrAX is included in JDK 1.4+.
    
    - `org.apache.ant:ant-nodeps` dependency has been removed since that artifact is no longer
relevant and is available as part of the core Ant dependency as per the release notes here[2]
    >> Removed ant-nodeps.jar; it is now merged into ant.jar.
    
    - Co-ordinates of `ant:ant-launcher` have now changed to `org.apache.ant:ant-launcher`
    
    [1] https://archive.apache.org/dist/ant/RELEASE-NOTES-apache-ant-1.8.1.html
    [2] https://archive.apache.org/dist/ant/RELEASE-NOTES-apache-ant-1.8.2.html

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/jaikiran/ant-ivy ant-upgrade

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/ant-ivy/pull/25.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #25
    
----
commit 4cd96fd67c9c6063d9a95aad43415ea794ec7a3e
Author: Jaikiran Pai <jaikiran.pai@gmail.com>
Date:   2017-05-21T13:47:15Z

    Upgrade to latest Ant release (non-Java 8 one)

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message