ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gintautas Grigelionis <g.grigelio...@gmail.com>
Subject Re: [VOTE] Increase minimum Java version for Ivy to Java7
Date Sat, 20 May 2017 11:56:49 GMT
Sorry for sloppy suggestion, I did not mean changing the subject. My
intention was to remind about another component which has Ivy as a direct
dependency and that it makes sense to align their baselines.

Gintas

2017-05-20 11:25 GMT+02:00 Nicolas Lalevée <nicolas.lalevee@hibnet.org>:

> Ant Bylaws is a good read to understand the process
> https://ant.apache.org/bylaws.html <https://ant.apache.org/bylaws.html>
>
> Since the initial question is about Ivy only, another vote will be needed
> for IvyDE.
>
> Nicolas
>
> > Le 20 mai 2017 à 04:47, J Pai <jai.forums2013@gmail.com> a écrit :
> >
> > Not fully familiar with the voting process and don’t know if IvyDE will
> require a voting thread of its own, but either way +1 for Java 7 for IvyDE
> too.
> >
> > -Jaikiran
> > On 19-May-2017, at 12:50 PM, Gintautas Grigelionis <
> g.grigelionis@gmail.com> wrote:
> >
> > Java 7 implements TLS 1.2; Ivy depends a lot more on network
> communications
> > than Ant does.
> > +1, but please extend the vote to the baseline of IvyDE as well.
> >
> > 2017-05-19 9:03 GMT+02:00 Maarten Coene <maarten_coene@yahoo.com.
> invalid>:
> >
> >> I think we should stick to Java5 as long as Ant 1.9.x is actively
> >> maintained.This keeps Ivy usable for both Ant 1.9.x and Ant 1.10.x
> >> Or are there good reasons to increase the minimum Java version, like
> >> features that cannot be implemented with Java 5?
> >> But since I don't have the time at the moment to be more active for the
> >> community, I will not block any decission made.
> >> So my vote is -0.
> >> Maarten
> >>
> >>
> >>     Van: Jan Matèrne <jan@materne.de>
> >> Aan: 'Ant Developers List' <dev@ant.apache.org>
> >> Verzonden: vrijdag 19 mei 7:25 2017
> >> Onderwerp: [VOTE] Increase minimum Java version for Ivy to Java7
> >>
> >> As discussed on this mailing list [1] we should increase the minimum
> Java
> >> version [2] from current (Ivy-2.4.0) Java5 to Java 7 (Ivy-2.5.0).
> >> Decisions whether to increase to Java8 after that release should be make
> >> after that release.
> >> According to the bylaws [3] this vote is open for one week (until
> >> 26.05.2017).
> >>
> >> Here is my +1
> >> Jan
> >>
> >> [1]
> >> http://mail-archives.apache.org/mod_mbox/ant-dev/201705.
> >> mbox/ajax/%3C87415C1
> >> F-5EFF-4C81-8078-0276CC21A8ED%40gmail.com%3E
> >> [2] http://ant.apache.org/ivy/history/latest-milestone/
> compatibility.html
> >> [3] http://ant.apache.org/bylaws.html
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> >> For additional commands, e-mail: dev-help@ant.apache.org
> >>
> >>
> >>
> >>
> >>
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
> > For additional commands, e-mail: dev-help@ant.apache.org
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message