ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: Early Access builds of JDK 8u112 b03, JDK 9 b128 are available on java.net
Date Mon, 01 Aug 2016 14:32:35 GMT
On 2016-08-01, dalibor topic wrote:

> I'd also suggest a sideways glance at
> https://bz.apache.org/bugzilla/show_bug.cgi?id=42838 again, in light
> of the current minimal platform requirements for Ant.

Sure, unfortunately the ticket only has people with strong opinions but
no code attached to it :-)

Seriously, Ant's javac facade would have been sufficient even back in
1.7.0 to provide an implementation based on JSR 199.  It just never
looked worth the effort if we needed to support the
com.sun.tools.javac.Main based entry point for older JDKs anyway.  For
Ant 1.9.x this still is true as Java5 is the target. We wouldn't drop
the code that has worked well for years in 1.10.x either.

One question to ask is what would improve for Ant if we used javax.tools
rather than keep the existing code. We wouldn't easily be able to take
advantage of anything the new API offers that went beyond our own
compiler abstraction without breaking those who implement the current
abstraction (this includes code outside of Ant like the adapter for
Eclipse's ejc).

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message