ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée <>
Subject Testing of a mirrored Eclipse P2 repository
Date Sun, 06 Nov 2011 22:54:38 GMT
Here is some update of the setup of the P2 repositories.
I think I have finished the build scripts. I have done some tests, and.... I don't know if
it works.

Short story: Eclipse is doing weird stuff, I don't understand what it is doing, I'll try to
investigate deeper later.

Longer story:
I have put some snapshot build of both Ivy and IvyDE and a p2 repo at
It references my two snapshot builds, plus some inexistent p2 repo on,
and I have my snapshot builds declared as mirrored on the apache mirrors.

The first phase which is about gathering metadata of the plugins, everything goes to people.a.o
and archive.a.o, as expected.

Then when I ask Eclipse to effectively install my plugins, I nicely get the mirror list.
I have seen it try to get my plugins from the mirrors, the url looks good, and it finds there
obviously nothing. That's OK. At some point it ends up trying to get the artifact not from
the mirror but from people.a.o. The plugins gets downloaded. Still OK.
But then I have seen very weird stuff...
It tried again to download the plugin from a mirror, hitting 404. And then it downloaded the
plugins about 10 times from people.a.o. Then it tried to get from another mirror. Then again
10 times download from people. And again and again.... for about 20 minutes...... until I
canceled the install.....
If you may, I would say, wtf ?

Maybe Eclipse doesn't like when so many mirrors are returning 404 ? Or when some repositories
are missing ?
I'll give another try later. Test with another site than people. Test without mirroring, without
archive.a.o, etc....


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message