ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 15031] - ANT <copy> with <fileset> does not spot bad symlinks
Date Mon, 14 Mar 2005 10:28:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=15031>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=15031





------- Additional Comments From bodewig@apache.org  2005-03-14 11:28 -------
Coming back to a really old report.

I completely agree that Ant is inconsistent here, even though it has come to behave
better in single-file copy here, it will report that the file doesn't exist (what
Conor notes below).

But this inconsistency goes further than just <copy>, we don't deal with those
unreadable/non-existant files in other tasks either.

As for the copy case, I'm afraid we are getting struck by backwards compatibility
again.  Touching the current beahvior would lead to breaking builds if we made
copy fail on bad symlinks.  All we could do was issuing a warning, IMHO.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message