ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Reilly <peter.rei...@corvil.com>
Subject Re: Ant 1.6.2
Date Fri, 03 Dec 2004 18:15:47 GMT
A number of things in ant 1.6.2 are slower that in ant 1.5.*.
For example use of antcall and ant.

However, for the most part things are as fast or faster (due
to lazy loading of tasks).

You may have hit a part of ant that has slowed down a lot, however
without more information it is impossible to help you.

Try to reduce your build system to the smaller possible
system that has the problem and put that into an attachement
in a bugzilla report.

Peter

Tony Thompson wrote:

>Can anyone provide some help here?
>
>  
>
>>>>tony.thompson@stone-ware.com 11/30/04 05:08PM >>>
>>>>        
>>>>
>Here is a number of messages that I posted on the Ant users list. 
>Someone suggested that I post them over here.  Can anyone help me with
>this?
>
>Thanks.
>Tony
>
>------------------------------------------------------------------------------------------------------------------------------
>
>Actually, I want to retract my previous message.  Even when I don't
>have
>debug on, if all of the extra "ant-*.jar" files are not in my
>classpath,
>everything still runs slow.
>
>Any idea what I can do?  I don't need all of those extra JAR files and
>I don't want to distribute them either.
>
>Tony
>
>  
>
>>>>Tony Thompson 11/23/04 12:02PM >>>
>>>>        
>>>>
>I am running Ant embedded and I have lots of typedefs (~675) in my
>script.  My build listener was displaying debug messages which was
>causing the slow down.  I am guessing something changed in
>AntTypeDefinition.getTypeClass() between 1.5 and 1.6.
>
>When my script executes, I get a whole batch of those error messages
>for each typedef in my script (I am estimating about 20 * 675).  The
>typedef I am using is a custom typdef.  I am not sure about the Ant
>internals but it seems like Ant is not behaving very nicely in this
>scenario.  Why is getTypeClass() called for all of those other classes
>when it should know the class required for my type?  Plus, it does it
>on
>every typedef.  Is there anything I can change in my script to make
>this
>better?
>
>Thanks.
>Tony
>
>  
>
>>>>Tony Thompson 11/22/04 01:25PM >>>
>>>>        
>>>>
>I am trying to upgrade to 1.6.2 and I am having issues with it running
>very slow.  When it finally starts, I get a bunch of error messages
>about missing classes:
>
>...
>Could not load class
>(org.apache.tools.ant.taskdefs.optional.vss.MSVSSCHECKIN) for type
>vsscheckin
>Could not load class
>(org.apache.tools.ant.taskdefs.optional.perforce.P4Reopen) for type
>p4reopen
>Could not load class
>(org.apache.tools.ant.taskdefs.optional.image.Image) for type image
>...
>
>Is there a way to disable all of the optional stuff?  I don't need any
>of it and it seems to be the thing slowing everything down.
>
>Thanks.
>Tony
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org 
>For additional commands, e-mail: dev-help@ant.apache.org 
>
>
>------------------------------------------------------------
>Mail was checked for spam by the Freeware Edition of No Spam Today!
>The Freeware Edition is free for personal and non-commercial use.
>You can remove this notice by purchasing a full license! To order
>or to find out more please visit: http://www.no-spam-today.com
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
>For additional commands, e-mail: dev-help@ant.apache.org
>
>
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message