ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Benson <>
Subject Re: cvs commit: ant/docs/manual/CoreTypes mapper.html
Date Fri, 12 Mar 2004 14:43:38 GMT
--- Stefan Bodewig <> wrote:
> One nit, though.  I don't like the name
> ContainerMapper.
> MapperContainer?  CompositeMapper?

Mine was called CompositeMapper.  We ended up going
with Peter's implementation, which was simpler and
included the paradigm shift (defs).  Peter's version
includes the "chained" attribute so it's possible to
get two (drastically) different behaviors from the
same class.  Under my design the two behaviors would
have come from two different classes, but anyway
because the chaining is possible the Mapper does not
HAVE to behave as a "CompositeMapper" although that is
the default.  Doesn't matter to me what it's called, I
just wanted to get it in there so I would have
something concrete against which I could test the
redirector stuff (I'm not committing those testcases
b/c I don't want redirectors to be tied to 1.7).  You
can put the name to a vote or duke it out with Peter. 


Do you Yahoo!?
Yahoo! Search - Find what you’re looking for faster

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message