ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Drost <>
Subject zipfileset issue
Date Sun, 30 Mar 2003 21:04:30 GMT
I'm in the process of extending the 'jar' task (for a bytecode instrumentation tool).  I want
modify classes as they are added to a the jar.  I definitely want to be able to use the
'zipfileset' type.  It appears as though the following operation works with Jakarta Ant 1.5,
does not work with Apache Ant 1.5.2.  When I do this under 1.5.2, the destination jar file
created, and appears to be the correct size, but I am unable to extract any of the content
for the manifest (with winzip).  

If I run and with verbose mode, I can see that the first time I run this task, it thinks it
adding the files.  

[jar] adding entry org/jboss/system/server/ServerImpl$ShutdownHook.class
[jar] adding entry org/jboss/system/server/ServerImpl.class
[jar] adding entry org/jboss/system/server/ServerImplMBean.class

The second time I run it, the task seems to know the archived file exists in the zip.

 [jar] org/jboss/system/server/ServerImpl$ShutdownHook.class omitted as
org/jboss/system/server/ServerImpl$ShutdownHook.class is up to date.
 [jar] org/jboss/system/server/ServerImpl.class omitted as
org/jboss/system/server/ServerImpl.class is up to date.
 [jar] org/jboss/system/server/ServerImplMBean.class omitted as
org/jboss/system/server/ServerImplMBean.class is up to date.

So, from Ant's point of view, everything succeeded.  In fact, the unjar task works w/o problem
the new jar file.  The problem is with loading classes from the jar, and opening it in Winzip.

<jar destfile="D:\jboss-3.0.6\lib\jboss-system.jar">
	<zipfileset src="D:\jboss-3.0.6\orig-lib\jboss-system.jar"/>

Is this behavior to be expected/understood?


Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!

View raw message