ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <>
Subject Re: API changes introduced while fixing bug 10755
Date Mon, 17 Feb 2003 13:53:19 GMT
On 07 Feb 2003, Stefan Bodewig <> wrote:

> One thing that I might want to see some stricter contract enforced
> is the name.

Done, mostly via javadocs.  Based on Bruce's suggestion it will ow
always use / as separator.

>> (3) New interface ResourceScanner
> I'm not convinced that this is really needed (at this point).

Has been removed.

>> (4) New utility class SourceSelector.
>> chosing some better names on the way.
> At least I hope so.  8-)

I've been convinced that either ResourceUtils or SelectorUtils would
be better - I'll look into the later (as it already exists) to see how
it fits.

> ZipScanner now wants a Task instance to log to.

Removed.  I've removed all debug output (which may make development a
slight bit more difficult) and turned the logged errors into


View raw message