ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Toomey <>
Subject Any Windows experts out there?????
Date Thu, 14 Feb 2002 05:25:16 GMT
Does anyone know why Ant running under a Service on W2K might not have
access to all environment variables (specifically Path)?

The following target gets different results depending on if it is run
from a command prompt or within a service:

<target name="testpath" >
<property environment="myenv" />
<echo message="PATH = ${myenv.Path}" />

If I run Ant in a command prompt, I get:

[property] Loading Environment myenv.
Setting project property: myenv.HOMEDRIVE -> c:
Setting project property: myenv.JAVA_HOME -> d:\programs\jdk1.3.1_02
Setting project property: myenv.Path ->
[echo] PATH =

If I run Ant from within a Service, I get:

Setting project property: myenv.JAVA_HOME -> d:\programs\jdk1.3.1_02
(all the same properties from above, except for Path)

Property ${myenv.Path} has not been set
[echo] PATH = ${myenv.Path}

Any ideas?????? 


Do You Yahoo!?
Send FREE Valentine eCards with Yahoo! Greetings!

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message