ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <>
Subject setZipFile(), setJarFile(), setWarFile --> setFile()
Date Wed, 12 Sep 2001 09:40:28 GMT

What does everyone think about using consistent naming on the zip related 
tasks. Currently subclasses add another method that just calls setZipFile().
Wouldn't it be better to have a single method setFile() that is used in all 
subclasses. We could deprecate the old name and give warnings on use and 
recomend new plain file="" attribute ???



"Marriage, Friends, Religon -- these are the demons 
you must slay in order to suceed in business.." 
                 -- Mr. Burns, The Simpsons 

View raw message