ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bobby Woolf <>
Subject Properties.load(InputStream) fails for EJB client run by Ant
Date Wed, 07 Feb 2001 16:36:46 GMT
I just submitted this bug to the Apache Bug Database as bug #542. The web
page suggested that I send the bug out to this mailing list as well. I
appreciate any help you can give me.



Bobby Woolf
Senior Architect
GemStone Systems, a Brokat company

Bugzilla Bug 542 

Properties.load(InputStream) fails for EJB client run by Ant 1.2

Ant seems to be having a problem handling classpaths for EJB clients. When I

run the client from Ant, I get a NullPointerException from Properties.load
(InputStream); the InputStream is null because the ClassLoader can't find
properties file in the EJB client jar (generated by the EJB container, 
GemStone/J) even though it's looking for the right file name with the right 
path. I know the client jar is in the classpath; when I take it out, the
fails with a ClassDefNotFoundException long before trying to load the 
properties. When I run the same clients using a .bat file (Windows NT batch 
file), the clients work, find the properties file, and connect to the server

properly. So Ant seems to be causing the failure.

A coworker who has used Ant more than me has reproduced the problem on his 
machine, can't find what's wrong, and says it seems to be an Ant bug. He has

done this sort of thing with Ant 1.1 and it worked, so this seems to be a

If you want my build.xml file or the exception stack trace, contact me at <>. Thanks for your

View raw message