ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Nordlund <>
Subject Re: Problems with the javac task.
Date Wed, 04 Oct 2000 07:52:17 GMT
Dirk Weigenand wrote:
> Hello Peter,
> from looking at the snippet of your classpath it looks like tools.jar from the
> JDK isn't contained in the classpath. I could be misinterperting the output
> but the following looks strange:
> !
> ^ here are some characters normally not in a path i guess. Could try
> reordering your classpath so
> /usr/local/development/java/jdk/Linux/from-ibm/1.3.0/lib/tools.jar is in the
> first part of your classpath?

- The strange characters do not appear in my copy of the mail, so I
guess they
appeared somwhere in the mail transfer.

Anyway, I tried your advice, and it didn't help.
I tried with ant-2000-10-03 and the same thing happens.
Do you understand what causes the exception? 

Could it be that the command somehow is to long for the compiler to
when invoked from inside ant?

I find it strange that when I just cut the command, as output
from my error printout, and invokes it on the command line it compiles
and generates a bunch of classfiles.
As I mentioned in a previous mail on this subject, no output files are
generated when this exception occurs.

In the provided example the command is 2971 characters but in other
cases when I have gotten the same exception the command has been 
just a bit more than 60000 characters long....


View raw message