ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diane Holt <>
Subject Problems running subproject <javac>'s
Date Sat, 16 Sep 2000 10:25:56 GMT
I have a subproject I call from my main build.xml thus:

  <target name="func" depends="demo">
    <ant antfile="functest.xml" dir="${functest.dir}"/>

The functest.xml has one target, "functest", which does several <javac>
tasks and a whole bunch of <copyfile>'s. When it does each of the
<javac>'s, it pops up (very briefly -- I'm guessing only while jikes is
actually executing) an empty DOS window (I run on NT under MKS korn
shell). This doesn't happen on the <javac> tasks I run out of build.xml --
only the ones out of functest.xml. Once the target hits the point where
one of the <javac>'s include names has a ** wildcard in it, I get the

    [javac] The following character string is too long:
build.xml:635: Compile failed, messages should have been provided.
Total time: 31 seconds

Any ideas on what could be causing this behaviour? Why the DOS window pop
up's, and the "string too long" error (which I'm assuming is coming from
DOS)?  None of this happens if I run these same <javac>'s from the top
level build.xml file. (But I was hoping not to have to do that, since this
target not only involves a bunch of <javac>'s but also a majillion file
copies, and I was hoping to keep the top-level build.xml relatively
succinct -- as it is, it's 832 lines, and there's still more to come.)



Do You Yahoo!?
Yahoo! Mail - Free email you can access from anywhere!

View raw message