ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mariusz Nowostawski <mari...@marni.otago.ac.nz>
Subject Re: Ant w/ Java 1.2.2
Date Tue, 15 Aug 2000 00:09:40 GMT
Hi Josh, 

Rebuild your ANT distro with jikes.  It should work when recompiled with
modern compiler from JDK 1.3, and it might work with javac compiler from
JDK 1.2.2, but it will for sure work correctly with the recent jikes.
This is a known problem with javac compiler from previous JDKs. 
(From my own experiences with my own inner classes, the only compiler
 which does not contain bugs in this area on Linux apart from jikes is the
 modern compiler from JDK 1.3)
Once you build ANT with decent compiler, you will have no problems using
it even with JDK 1.1.*


Hth
Mariusz

On Mon, 14 Aug 2000, Josh Lucas wrote:
> I'm currently trying to run the current CVS with JDK 1.2.2 on Linux.  I
> can build it without any problems but when I try to run Ant, I'm getting
> a java.lang.VerifyError in ProjectHelper$TaskHandler.  It says that the
> init method has an illegal use of an nonvirtual function call.
> 
> I'm assuming that there is something wrong in my CLASSPATH.  Has anyone
> seen this before?


Mime
View raw message