ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Forslund <>
Subject Re: [PATCH] exec with include/exclude
Date Sat, 27 May 2000 00:08:27 GMT
At 11:50 AM 5/27/00 +1200, Mariusz Nowostawski wrote:
>I have not checked that on windows, I run simple tests locally here on
>Linux only, but I suspect it should work on both the same.
>If your target looks something like this:
><target name="idls">
>     <exec dir="."
>           command="jidl --output-dir classes --package"
>           src="idls" output="out.txt"/>
>and inside ./idls you have your *.idl sources:
>0. Invoke: ant idls
>1. Check what you have after execution of the idls target inside out.txt;
>    in normal conditions this file should be empty, but if your jidl has
>    any troubles you can get the idea whats wrong from out.txt
>2. Make sure the output dir is already created (jidl I am using will
>    simply fail if you do not have output directory already created)
>3. If you still cannot guess whats wrong, show me your out.txt file, your
>    target and what ant is printing out when you executing idls target

The out.txt file is empty (it was not empty when the command was failing).
The command works just fine, it seems to open a new command window
for every .idl file it is compiling  (it doesn't do this when running the 
same command outside
of ant).  The output directory is full.  The command seems to work 
correctly and creates
all the necessary files.    I can't send you want jidl is printing out, 
because all the
windows go away when the command completes.

It alls seems to work, it just pops the annoying windows while it is running.



>As I said, I am using Linux, and I have not noticed any troubles here,
>with target like the one above, with jidl being ORBacus 3.1.3, I have:
>   my out.txt is empty,
>   ant is printing:
>$ ant idls
>Buildfile: build.xml
>Project base dir set to: /home/mariusz/Projects/nzdis/oql
>Executing Target: idls
>[exec] jidl --output-dir classes --package in 
>/home/mariusz/Projects/nzdis/oql for 3 files.
>Completed in 1 seconds
>   and inside classes/com/my/idl/* I have the expected java sources written
>correctly to disk.  I have not checked that on windows though..
>hope it helps
> > I tried the patch and find the jidl program opens up a bunch of command
> > windows on NT and although jidl appears to process the idl files,
> > nothing is written to disk.
> >
> > Dave

View raw message