sqoop-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From b...@apache.org
Subject git commit: SQOOP-715 Add support for Hadoop 1 to addtowar.sh script (Jarek Jarcec Cecho)
Date Tue, 20 Nov 2012 01:52:42 GMT
Updated Branches:
  refs/heads/sqoop2 28a3c007a -> 28758559e


SQOOP-715 Add support for Hadoop 1 to addtowar.sh script
(Jarek Jarcec Cecho)


Project: http://git-wip-us.apache.org/repos/asf/sqoop/repo
Commit: http://git-wip-us.apache.org/repos/asf/sqoop/commit/28758559
Tree: http://git-wip-us.apache.org/repos/asf/sqoop/tree/28758559
Diff: http://git-wip-us.apache.org/repos/asf/sqoop/diff/28758559

Branch: refs/heads/sqoop2
Commit: 28758559e97830d6d94c34f2792cdc0a3a2d7a58
Parents: 28a3c00
Author: Bilung Lee <blee@apache.org>
Authored: Mon Nov 19 17:51:08 2012 -0800
Committer: Bilung Lee <blee@apache.org>
Committed: Mon Nov 19 17:51:08 2012 -0800

----------------------------------------------------------------------
 dist/src/main/bin/addtowar.sh |   27 +++++----------------------
 1 files changed, 5 insertions(+), 22 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/sqoop/blob/28758559/dist/src/main/bin/addtowar.sh
----------------------------------------------------------------------
diff --git a/dist/src/main/bin/addtowar.sh b/dist/src/main/bin/addtowar.sh
index e5c4a85..fb65d35 100644
--- a/dist/src/main/bin/addtowar.sh
+++ b/dist/src/main/bin/addtowar.sh
@@ -96,33 +96,16 @@ function checkOption() {
 # TODO(jarcec): Add configuration specific to Hadoop 1.x
 function getHadoopJars() {
   version=$1
-#   Commented distributions are not tested
-#  if [ "${version}" = "0.20.1" ]; then
-#    #List is separated by ":"
-#    hadoopJars="hadoop-core*.jar"
-#  elif [ "${version}" = "0.20.2" ]; then
-#    #List is separated by ":"
-#    hadoopJars="hadoop-core*.jar"
-#  elif [ "${version}" = "0.20.104" ]; then
-#    #List is separated by ":"
-#    hadoopJars="hadoop-core*.jar:jackson-core-asl-*.jar:jackson-mapper-asl-*.jar"
-#  elif [ "${version}" = "0.20.200" ]; then
-#    #List is separated by ":"
-#    hadoopJars="hadoop-core*.jar:jackson-core-asl-*.jar:jackson-mapper-asl-*.jar:commons-configuration-*.jar"
-#  elif [[ "${version}" =~ .*23 ]]; then
-#    suffix="-[0-9.]*"
-#    #List is separated by ":"
-#    hadoopJars="hadoop-mapreduce-client-core${suffix}.jar:hadoop-mapreduce-client-common${suffix}.jar:hadoop-mapreduce-client-jobclient${suffix}.jar:hadoop-mapreduce-client-app${suffix}.jar:hadoop-yarn-common${suffix}.jar:hadoop-yarn-api${suffix}.jar:hadoop-hdfs${suffix}.jar:hadoop-common${suffix}.jar:hadoop-auth${suffix}.jar:guava*.jar:protobuf-*.jar:avro-ipc-*.jar:jackson-core-asl-*.jar:jackson-mapper-asl-*.jar:commons-configuration-*.jar"
-#  elif [[ "${version}" =~ 2.* ]]; then
-  if [[ "${version}" =~ 2.* ]]; then
+  if [[ "${version}" =~ 1.* ]]; then
+    #List is separated by ":"
+    hadoopJars="hadoop-core*.jar:jackson-core-asl-*.jar:jackson-mapper-asl-*.jar:commons-configuration-*.jar:commons-logging-*.jar:slf4j-api-*.jar:slf4j-log4j*.jar"
+  elif [[ "${version}" =~ 2.* ]]; then
     suffix="-[0-9.]*"
     # List is separated by ":"
-    # Removed hadoop-yarn-client${suffix}.jar, my distribution do not have such artifact?
     hadoopJars="hadoop-mapreduce-client-core${suffix}.jar:hadoop-mapreduce-client-common${suffix}.jar:hadoop-mapreduce-client-jobclient${suffix}.jar:hadoop-mapreduce-client-app${suffix}.jar:hadoop-yarn-common${suffix}.jar:hadoop-yarn-api${suffix}.jar:hadoop-hdfs${suffix}.jar:hadoop-common${suffix}.jar:hadoop-auth${suffix}.jar:guava*.jar:protobuf-*.jar:jackson-core-asl-*.jar:jackson-mapper-asl-*.jar:commons-configuration-*.jar:commons-cli-*.jar:commons-logging-*.jar:slf4j-api-*.jar:slf4j-log4j*.jar:avro-*.jar"
   else
     echo
-    echo "Exiting: Unsupported Hadoop version '${hadoopVer}', supported versions: 2.x"
-#    echo "Exiting: Unsupported Hadoop version '${hadoopVer}', supported versions: 0.20.1,
0.20.2, 0.20.104, 0.20.200, 0.23.x and 2.x"
+    echo "Exiting: Unsupported Hadoop version '${hadoopVer}', supported versions: 1.x, 2.x"
     echo
     cleanUp
     exit -1;


Mime
View raw message