sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From desruisse...@apache.org
Subject [sis] branch geoapi-4.0 updated: Upgrade dependencies.
Date Wed, 17 Feb 2021 19:56:30 GMT
This is an automated email from the ASF dual-hosted git repository.

desruisseaux pushed a commit to branch geoapi-4.0
in repository https://gitbox.apache.org/repos/asf/sis.git


The following commit(s) were added to refs/heads/geoapi-4.0 by this push:
     new 5dfb974  Upgrade dependencies.
5dfb974 is described below

commit 5dfb9740c8812ca067f410563e5a741bf55a10cf
Author: Martin Desruisseaux <martin.desruisseaux@geomatys.com>
AuthorDate: Wed Feb 17 20:56:13 2021 +0100

    Upgrade dependencies.
---
 ide-project/NetBeans/nbproject/project.properties | 16 ++++++++--------
 pom.xml                                           | 22 +++++++++++-----------
 2 files changed, 19 insertions(+), 19 deletions(-)

diff --git a/ide-project/NetBeans/nbproject/project.properties b/ide-project/NetBeans/nbproject/project.properties
index e002d4d..50860be 100644
--- a/ide-project/NetBeans/nbproject/project.properties
+++ b/ide-project/NetBeans/nbproject/project.properties
@@ -106,29 +106,29 @@ project.GeoAPI       = ../../../../GeoAPI/master/ide-project/NetBeans
 # Those numbers should match the ones declared in the pom.xml files.
 #
 jsr363.version       = 1.0
-jaxb.version         = 2.3.2
+jaxb.version         = 2.3.3
 istack.version       = 3.0.8
 activation.version   = 1.1
 jama.version         = 1.0.3
-geographlib.version  = 1.50
+geographlib.version  = 1.51
 guava.version        = 27.0.1-jre
-esri.api.version     = 2.2.3
-jts.version          = 1.16.1
+esri.api.version     = 2.2.4
+jts.version          = 1.18.0
 jdom1.version        = 1.0
 jdom2.version        = 2.0.4
 jee.version          = 8.0.1
 osgi.version         = 6.0.0
-netcdf.version       = 4.6.14
+netcdf.version       = 4.6.15
 joda-time.version    = 2.8.1
 httpclient.version   = 4.5.1
 httpcore.version     = 4.4.4
 cm-logging.version   = 1.2
 slf4j.version        = 1.7.22
-junit.version        = 4.12
+junit.version        = 4.13.2
 hamcrest.version     = 1.3
 derby.version        = 10.14.2.0
-hsqldb.version       = 2.5.0
-postgresql.version   = 42.2.8
+hsqldb.version       = 2.5.1
+postgresql.version   = 42.2.18
 icons.version        = 3.0.1
 
 #
diff --git a/pom.xml b/pom.xml
index 5c372bf..b03bd02 100644
--- a/pom.xml
+++ b/pom.xml
@@ -39,7 +39,7 @@
   <parent>
     <groupId>org.apache</groupId>
     <artifactId>apache</artifactId>
-    <version>21</version>
+    <version>23</version>
   </parent>
 
 
@@ -446,13 +446,13 @@
       <dependency>
         <groupId>com.esri.geometry</groupId>
         <artifactId>esri-geometry-api</artifactId>
-        <version>2.2.3</version>
+        <version>2.2.4</version>
         <optional>true</optional>
       </dependency>
       <dependency>
         <groupId>org.locationtech.jts</groupId>
         <artifactId>jts-core</artifactId>
-        <version>1.17.0</version>
+        <version>1.18.0</version>
         <optional>true</optional>
       </dependency>
       <dependency>
@@ -464,7 +464,7 @@
       <dependency>
         <groupId>net.sf.geographiclib</groupId>
         <artifactId>GeographicLib-Java</artifactId>
-        <version>1.50</version>
+        <version>1.51</version>
         <scope>test</scope>
       </dependency>
       <dependency>
@@ -488,7 +488,7 @@
       <dependency>
         <groupId>org.apache.commons</groupId>
         <artifactId>commons-compress</artifactId>
-        <version>1.19</version>
+        <version>1.20</version>
       </dependency>
 
       <!-- Databases -->
@@ -501,13 +501,13 @@
       <dependency>
         <groupId>org.hsqldb</groupId>
         <artifactId>hsqldb</artifactId>
-        <version>2.5.0</version>
+        <version>2.5.1</version>
         <scope>test</scope>
       </dependency>
       <dependency>
         <groupId>org.postgresql</groupId>
         <artifactId>postgresql</artifactId>
-        <version>42.2.8</version>
+        <version>42.2.18</version>
         <scope>test</scope>
       </dependency>
 
@@ -546,13 +546,13 @@
     <dependency>
       <groupId>org.junit.jupiter</groupId>
       <artifactId>junit-jupiter</artifactId>
-      <version>5.5.2</version>
+      <version>5.8.0-M1</version>
       <scope>test</scope>
     </dependency>
     <dependency>
       <groupId>org.junit.vintage</groupId>
       <artifactId>junit-vintage-engine</artifactId>
-      <version>5.5.2</version>
+      <version>5.8.0-M1</version>
       <scope>test</scope>
     </dependency>
     <dependency>   <!-- To be removed after https://issues.apache.org/jira/browse/SIS-469
is done. -->
@@ -569,7 +569,7 @@
          The last properties in this list depend on the Apache SIS branch.
        =================================================================== -->
   <properties>
-    <netcdf.version>4.6.14</netcdf.version>
+    <netcdf.version>4.6.15</netcdf.version>
     <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
     <website.encoding>UTF-8</website.encoding>
     <website.locale>en</website.locale>
@@ -581,7 +581,7 @@
     <sis.non-free.version>1.0</sis.non-free.version>                <!-- Used
only if "non-free" profile is activated. -->
     <javafx.version>14.0.1</javafx.version>                         <!-- Used
only if "javafx" profile is activated. -->
     <geoapi.version>4.0-SNAPSHOT</geoapi.version>
-    <jaxb.version>2.3.2</jaxb.version>
+    <jaxb.version>2.3.3</jaxb.version>
   </properties>
 
   <profiles>


Mime
View raw message