sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Desruisseaux (Jira)" <j...@apache.org>
Subject [jira] [Commented] (SIS-503) Naming issue in setters of DefaultReleasability
Date Tue, 17 Nov 2020 18:14:00 GMT

    [ https://issues.apache.org/jira/browse/SIS-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17233801#comment-17233801
] 

Martin Desruisseaux commented on SIS-503:
-----------------------------------------

Good catch, thanks for reporting! We will fix this week. The old methods will be deprecated
for SIS 1.1 release, and removed in 1.2 release.

> Naming issue in setters of DefaultReleasability
> -----------------------------------------------
>
>                 Key: SIS-503
>                 URL: https://issues.apache.org/jira/browse/SIS-503
>             Project: Spatial Information Systems
>          Issue Type: Bug
>          Components: Metadata
>    Affects Versions: 2.0
>            Reporter: jean-marc Bourdaret
>            Priority: Minor
>   Original Estimate: 10m
>  Remaining Estimate: 10m
>
> In DefaultReleasability.java , some setters have the same name as getters:
> {color:#8c8c8c}
> {color}{color:#0033b3}public void {color}{color:#00627a}*{color:#FF0000}get{color}*Addressees{color}({color:#0033b3}final
{color}{color:#000000}Collection{color}<? {color:#0033b3}extends {color}{color:#000000}Responsibility{color}>
newValues) 
> {color:#0033b3}public void {color}{color:#00627a}{color:#FF0000}*get*{color}DisseminationConstraints{color}({color:#0033b3}final
{color}{color:#000000}Collection{color}<? {color:#0033b3}extends {color}{color:#000000}Restriction{color}>
newValues) 
>  
> should be named with set* instead of get*



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message