sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Desruisseaux (Jira)" <j...@apache.org>
Subject [jira] [Updated] (SIS-492) Remove support for JavaDB (JDK 8)
Date Mon, 09 Mar 2020 22:36:00 GMT

     [ https://issues.apache.org/jira/browse/SIS-492?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Martin Desruisseaux updated SIS-492:
------------------------------------
    Summary: Remove support for JavaDB (JDK 8)  (was: Remove support for JavaDB)

> Remove support for JavaDB (JDK 8)
> ---------------------------------
>
>                 Key: SIS-492
>                 URL: https://issues.apache.org/jira/browse/SIS-492
>             Project: Spatial Information Systems
>          Issue Type: Task
>          Components: Metadata, Referencing
>    Affects Versions: 1.0
>            Reporter: Martin Desruisseaux
>            Assignee: Martin Desruisseaux
>            Priority: Minor
>             Fix For: 1.1
>
>
> Apache SIS was used to try to open the {{SpatialMetadata}} database (which contains the
EPSG dataset) using the Derby driver on the classpath, or if no such driver is found using
the JavaDB driver embedded in the JDK from Java 6 to Java 8. But JavaDB has been removed from
the JDK in Java 9. We nevertheless kept the code looking for JavaDB because SIS was still
compatible with Java 8. But even JDK 8 removed JavaDB since update 181 (JDK 8u181). That update
expired one year and half ago, in October 16, 2018 (was released in July 17, 2018). Consequently
there is no longer any reason to keep the code looking for JavaDB.
> * Reference: [Update 181 release note|https://www.oracle.com/technetwork/java/javase/8u181-relnotes-4479407.html]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message