sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From desruisse...@apache.org
Subject [sis] 01/01: Merge branch 'geoapi-4.0' into geoapi-3.1: make Apache SIS compatible with Java 11+. https://issues.apache.org/jira/browse/SIS-438
Date Mon, 02 Sep 2019 13:50:23 GMT
This is an automated email from the ASF dual-hosted git repository.

desruisseaux pushed a commit to branch geoapi-3.1
in repository https://gitbox.apache.org/repos/asf/sis.git

commit 3363d3ce6469f952fab2850dc4c813093789982c
Merge: 83846c5 ae989c9
Author: Martin Desruisseaux <martin.desruisseaux@geomatys.com>
AuthorDate: Mon Sep 2 15:41:23 2019 +0200

    Merge branch 'geoapi-4.0' into geoapi-3.1: make Apache SIS compatible with Java 11+.
    https://issues.apache.org/jira/browse/SIS-438

 NOTICE                                             |  11 +-
 application/pom.xml                                |  17 ++-
 application/sis-console/pom.xml                    |   5 +
 application/sis-javafx/pom.xml                     |   5 +-
 .../org/apache/sis/internal/gui/Resources.java     |   2 +-
 core/sis-metadata/pom.xml                          |  13 +-
 .../apache/sis/internal/jaxb/gco/package-info.java |   5 +-
 .../java/org/apache/sis/xml/Implementation.java    |  32 ++---
 .../java/org/apache/sis/xml/MarshallerPool.java    |  25 +---
 .../apache/sis/xml/OGCNamespacePrefixMapper.java   |  79 ------------
 .../sis/xml/OGCNamespacePrefixMapper_Endorsed.java |  73 -----------
 .../src/main/java/org/apache/sis/xml/XML.java      |   7 +-
 .../apache/sis/test/suite/MetadataTestSuite.java   |   1 -
 .../org/apache/sis/xml/MarshallerPoolTest.java     |   2 -
 .../sis/xml/OGCNamespacePrefixMapperTest.java      | 134 ---------------------
 core/sis-referencing/pom.xml                       |   9 ++
 ide-project/NetBeans/nbproject/build-impl.xml      |  47 +++-----
 ide-project/NetBeans/nbproject/genfiles.properties |   4 +-
 ide-project/NetBeans/nbproject/project.properties  |  43 ++++---
 ide-project/NetBeans/nbproject/project.xml         |   2 -
 pom.xml                                            |  24 +++-
 profiles/sis-french-profile/pom.xml                |   5 +
 storage/sis-storage/pom.xml                        |   5 +
 storage/sis-xmlstore/pom.xml                       |   5 +
 24 files changed, 137 insertions(+), 418 deletions(-)

diff --cc ide-project/NetBeans/nbproject/genfiles.properties
index 56a977b,33afce4..2039f39
--- a/ide-project/NetBeans/nbproject/genfiles.properties
+++ b/ide-project/NetBeans/nbproject/genfiles.properties
@@@ -3,6 -3,6 +3,6 @@@
  build.xml.data.CRC32=58e6b21c
  build.xml.script.CRC32=462eaba0
  build.xml.stylesheet.CRC32=28e38971@1.53.1.46
- nbproject/build-impl.xml.data.CRC32=5a726ec7
- nbproject/build-impl.xml.script.CRC32=f4ace637
 -nbproject/build-impl.xml.data.CRC32=aba75efd
 -nbproject/build-impl.xml.script.CRC32=9e0e11c0
++nbproject/build-impl.xml.data.CRC32=c66331aa
++nbproject/build-impl.xml.script.CRC32=a8b9b922
  nbproject/build-impl.xml.stylesheet.CRC32=3a2fa800@1.92.0.48
diff --cc ide-project/NetBeans/nbproject/project.properties
index 5c0589c,bf11345..3c762ce
--- a/ide-project/NetBeans/nbproject/project.properties
+++ b/ide-project/NetBeans/nbproject/project.properties
@@@ -98,8 -103,10 +96,11 @@@ test.jpn-profile.dir = ${project.root}/
  # Those dependencies must exist in the local Maven repository.
  # Those numbers should match the ones declared in the pom.xml files.
  #
 +geoapi.version       = 3.1-SNAPSHOT
  jsr363.version       = 1.0
+ jaxb.version         = 2.3.2
+ istack.version       = 3.0.8
+ activation.version   = 1.1
  jama.version         = 1.0.3
  geographlib.version  = 1.49
  guava.version        = 27.0.1-jre
@@@ -132,8 -138,9 +132,9 @@@ icons.version        = 3.0.
  maven.repository   = ${user.home}/.m2/repository
  endorsed.classpath =
  javac.classpath=\
 -    ${project.GeoAPI}/dist/geoapi.jar:\
 +    ${maven.repository}/org/opengis/geoapi-pending/${geoapi.version}/geoapi-pending-${geoapi.version}.jar:\
      ${maven.repository}/javax/measure/unit-api/${jsr363.version}/unit-api-${jsr363.version}.jar:\
+     ${maven.repository}/jakarta/xml/bind/jakarta.xml.bind-api/${jaxb.version}/jakarta.xml.bind-api-${jaxb.version}.jar:\
      ${maven.repository}/com/esri/geometry/esri-geometry-api/${esri.api.version}/esri-geometry-api-${esri.api.version}.jar:\
      ${maven.repository}/org/locationtech/jts/jts-core/${jts.version}/jts-core-${jts.version}.jar:\
      ${maven.repository}/org/geonames/georss-rome/${georss.version}/georss-rome-${georss.version}.jar:\
diff --cc pom.xml
index 35eb654,c793b97..16aae5e
--- a/pom.xml
+++ b/pom.xml
@@@ -547,7 -565,8 +565,8 @@@
      <maven.compiler.target>8</maven.compiler.target>
      <sis.plugin.version>${project.version}</sis.plugin.version>
      <sis.non-free.version>1.0-M1</sis.non-free.version>                 <!--
Used only if "non-free" profile is enabled. -->
 -    <geoapi.version>4.0-SNAPSHOT</geoapi.version>
 +    <geoapi.version>3.1-SNAPSHOT</geoapi.version>
+     <jaxb.version>2.3.2</jaxb.version>
    </properties>
  
    <profiles>


Mime
View raw message