sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From desruisse...@apache.org
Subject svn commit: r1866279 - in /sis/site/trunk/content: downloads.mdtext index.mdtext
Date Mon, 02 Sep 2019 13:22:10 GMT
Author: desruisseaux
Date: Mon Sep  2 13:22:09 2019
New Revision: 1866279

URL: http://svn.apache.org/viewvc?rev=1866279&view=rev
Log:
Update information about required Java versions.

Modified:
    sis/site/trunk/content/downloads.mdtext
    sis/site/trunk/content/index.mdtext

Modified: sis/site/trunk/content/downloads.mdtext
URL: http://svn.apache.org/viewvc/sis/site/trunk/content/downloads.mdtext?rev=1866279&r1=1866278&r2=1866279&view=diff
==============================================================================
--- sis/site/trunk/content/downloads.mdtext [UTF-8] (original)
+++ sis/site/trunk/content/downloads.mdtext [UTF-8] Mon Sep  2 13:22:09 2019
@@ -76,7 +76,8 @@ Download as a Maven dependency    {#mave
 
 An easy approach to integrate Apache SIS into a Java project uses the [Apache Maven][maven]
 dependency management tool to automatically obtain the required Java Archives (JAR) files
from the network.
-Below are examples of declarations in a `pom.xml` file for building a project with the SIS
core module:
+Below are examples of declarations in a `pom.xml` file for building a project with a SIS
core module.
+If running on Java 11 or higher, _one_ of the two next dependencies is also required:
 
     :::xml
     <properties>

Modified: sis/site/trunk/content/index.mdtext
URL: http://svn.apache.org/viewvc/sis/site/trunk/content/index.mdtext?rev=1866279&r1=1866278&r2=1866279&view=diff
==============================================================================
--- sis/site/trunk/content/index.mdtext [UTF-8] (original)
+++ sis/site/trunk/content/index.mdtext [UTF-8] Mon Sep  2 13:22:09 2019
@@ -51,9 +51,10 @@ Some Apache SIS features are:
 Using Apache SIS    {#user}
 ---------------------------
 The latest SIS release is 0.8, released November 2017.
-Apache SIS requires Java 8 or higher together with JAXB.
+Apache SIS requires Java 10 or higher for building, but can be executed on Java 8 or higher.
 If using Java 8 Runtime Environment, nothing else is needed since Java 8 includes JAXB.
-If using Java 9 or higher, one of the following configurations is needed:
+If using Java 9 or higher, one of the following configurations is needed
+(those extra configurations are temporary until support for Java 8 will be dropped in a future
SIS version):
 
   * "`--add-modules java.xml.bind,java.xml.ws.annotation`" option (available with Java 9
or 10 only) added to the `java` command
   * or JAXB dependency added from Glassfish or Jakarata projects. See [Maven coordinates](downloads.html#maven).



Mime
View raw message