sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From desruisse...@apache.org
Subject [sis] 01/02: Update dependencies.
Date Tue, 27 Aug 2019 15:12:20 GMT
This is an automated email from the ASF dual-hosted git repository.

desruisseaux pushed a commit to branch geoapi-4.0
in repository https://gitbox.apache.org/repos/asf/sis.git

commit 154e065742b6e802e23d5d42d30f24d567c90497
Author: Martin Desruisseaux <martin.desruisseaux@geomatys.com>
AuthorDate: Tue Aug 27 15:04:08 2019 +0200

    Update dependencies.
---
 ide-project/NetBeans/nbproject/project.properties |  8 ++++----
 pom.xml                                           | 18 +++++++++---------
 2 files changed, 13 insertions(+), 13 deletions(-)

diff --git a/ide-project/NetBeans/nbproject/project.properties b/ide-project/NetBeans/nbproject/project.properties
index 8e3cb3d..f763faf 100644
--- a/ide-project/NetBeans/nbproject/project.properties
+++ b/ide-project/NetBeans/nbproject/project.properties
@@ -108,7 +108,7 @@ project.GeoAPI       = ../../../../GeoAPI/master/ide-project/NetBeans
 jsr363.version       = 1.0
 jama.version         = 1.0.3
 geographlib.version  = 1.49
-guava.version        = 18.0
+guava.version        = 27.0.1-jre
 esri.api.version     = 2.2.2
 jts.version          = 1.16.1
 georss.version       = 0.9.8
@@ -117,7 +117,7 @@ jdom1.version        = 1.0
 jdom2.version        = 2.0.4
 jee.version          = 8.0
 osgi.version         = 6.0.0
-netcdf.version       = 4.6.13
+netcdf.version       = 4.6.14
 joda-time.version    = 2.8.1
 httpclient.version   = 4.5.1
 httpcore.version     = 4.4.4
@@ -127,8 +127,8 @@ junit.version        = 4.12
 hamcrest.version     = 1.3
 jaxb-ns-mapper       = 2.2.4
 derby.version        = 10.14.2.0
-hsqldb.version       = 2.4.1
-postgresql.version   = 42.2.5
+hsqldb.version       = 2.5.0
+postgresql.version   = 42.2.6
 icons.version        = 3.0.1
 
 #
diff --git a/pom.xml b/pom.xml
index 3152daf..1436c89 100644
--- a/pom.xml
+++ b/pom.xml
@@ -479,19 +479,19 @@
       <dependency>
         <groupId>org.apache.derby</groupId>
         <artifactId>derby</artifactId>
-        <version>10.14.2.0</version>
+        <version>10.14.2.0</version>        <!-- 10.14 is the last series
compatible with JDK 8. -->
         <scope>test</scope>
       </dependency>
       <dependency>
         <groupId>org.hsqldb</groupId>
         <artifactId>hsqldb</artifactId>
-        <version>2.4.1</version>
+        <version>2.5.0</version>
         <scope>test</scope>
       </dependency>
       <dependency>
         <groupId>org.postgresql</groupId>
         <artifactId>postgresql</artifactId>
-        <version>42.2.5</version>
+        <version>42.2.6</version>
         <scope>test</scope>
       </dependency>
 
@@ -537,7 +537,7 @@
          The last properties in this list depend on the Apache SIS branch.
        =================================================================== -->
   <properties>
-    <netcdf.version>4.6.13</netcdf.version>
+    <netcdf.version>4.6.14</netcdf.version>
     <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
     <website.encoding>UTF-8</website.encoding>
     <website.locale>en</website.locale>
@@ -677,7 +677,7 @@
            INDEX.LIST file is incomplete (which seem to happen in practice). -->
       <plugin>
         <artifactId>maven-jar-plugin</artifactId>
-        <version>3.1.1</version>
+        <version>3.1.2</version>
         <configuration>
           <archive>
             <addMavenDescriptor>false</addMavenDescriptor>
@@ -728,12 +728,12 @@
       <plugin>
         <groupId>org.apache.maven.plugins</groupId>
         <artifactId>maven-checkstyle-plugin</artifactId>
-        <version>3.0.0</version>
+        <version>3.1.0</version>
         <dependencies>
           <dependency>
             <groupId>com.puppycrawl.tools</groupId>
             <artifactId>checkstyle</artifactId>
-            <version>8.20</version>
+            <version>8.23</version>
           </dependency>
         </dependencies>
         <executions>
@@ -835,7 +835,7 @@
       <!-- JavaDoc configuration. -->
       <plugin>
         <artifactId>maven-javadoc-plugin</artifactId>
-        <version>3.0.1</version>
+        <version>3.1.1</version>
         <configuration>
           <source>${maven.compiler.source}</source>             <!-- Enables
javadoc to handle language constructs present in target JDK. -->
           <encoding>${project.build.sourceEncoding}</encoding>  <!-- Encoding
of Java source file. -->
@@ -952,7 +952,7 @@
         <plugin>
           <groupId>org.eclipse.jetty</groupId>
           <artifactId>jetty-maven-plugin</artifactId>
-          <version>9.4.15.v20190215</version>
+          <version>9.4.20.v20190813</version>
         </plugin>
       </plugins>
     </pluginManagement>


Mime
View raw message