sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject [sis] branch master updated (4610eab -> 09ba94f)
Date Wed, 01 May 2019 20:55:16 GMT
This is an automated email from the ASF dual-hosted git repository.

desruisseaux pushed a change to branch master
in repository

    from 4610eab  Merge branch 'geoapi-3.1'. Contains work on netCDF reader and addition of
two map projections.
     add 1f0fbb9  Fix a thread-safety hole.
     add 24fcb0f  Implements GridEnvelope and GridCoordinates following resolution of
     add 77720b8  Merge branch 'geoapi-4.0' into geoapi-3.1: implementation of GridEnvelope
     new cdc04d4  Merge branch 'geoapi-3.1' excluding the use of `GridEnvelope` interface
(because not present in GeoAPI 3.0).
     add fceec82  Fix missing "s" in "getOrderOptionsType()" for ISO 19115 compliance.
     add 59b5551  Fix spelling error in method name, but not in XML annotation since the spelling
exists in ISO specification.
     add 9426368  Merge branch 'geoapi-4.0' into geoapi-3.1 but without the change in Objective.getObjectiveOccurences()
method name. The old name is kept on GeoAPI 3.1 branch for compatibility reason.
     add 2492289  Rename "polarization" as "polarisation" in two method names for compliance
with latest ISO 19115 revision.
     add d6b8565  Renamed PolarizationOrientation as PolarisationOrientation for compliance
with latest ISO 19115-2 revision. Part of
     add f7fb545  Merge branch 'geoapi-4.0' into geoapi-3.1, taking only the renaming in annotations.
Renaming of methods or classes are not taken for compatibility reasons.
     add bf56b15  Renamed getCenterPoint() as getCentrePoint() for compliance with ISO 19115:2014.
     add 8164ff4  Merge branch 'geoapi-4.0' into geoapi-3.1, but replacing method renaming
by a comment about future evolution.
     new 09ba94f  Merge branch 'geoapi-3.1' with some methods renamings replaced by comments
about future evolution.

The 2 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.

Summary of changes:
 .../org/apache/sis/internal/book/GEOAPI.lst        |  2 +-
 .../resources/org/apache/sis/internal/book/OGC.lst |  2 +- =>} | 12 +++---
 .../apache/sis/metadata/   |  3 +-
 .../metadata/iso/acquisition/ | 24 ++++++-----
 .../sis/metadata/iso/content/      | 20 ++++++++++
 .../sis/metadata/iso/content/     |  6 +--
 .../distribution/  | 46 ++++++++++++++++------
 .../metadata/iso/spatial/  |  8 ++++
 .../apache/sis/metadata/iso/   |  8 +++-
 .../apache/sis/metadata/iso/ |  2 +-
 .../sis/coverage/grid/     |  4 +-
 .../org/apache/sis/coverage/grid/   | 10 +----
 13 files changed, 101 insertions(+), 46 deletions(-)
 rename core/sis-metadata/src/main/java/org/apache/sis/internal/jaxb/code/{
=>} (88%)

View raw message