sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From desruisse...@apache.org
Subject [sis] branch geoapi-3.1 updated (2751173 -> 8164ff4)
Date Wed, 01 May 2019 16:01:15 GMT
This is an automated email from the ASF dual-hosted git repository.

desruisseaux pushed a change to branch geoapi-3.1
in repository https://gitbox.apache.org/repos/asf/sis.git.


    from 2751173  Merge branch 'geoapi-4.0' into geoapi-3.1. Contains work on netCDF and addition
of two map projections.
     add 1f0fbb9  Fix a thread-safety hole.
     add 24fcb0f  Implements GridEnvelope and GridCoordinates following resolution of https://github.com/opengeospatial/geoapi/issues/36
     new 77720b8  Merge branch 'geoapi-4.0' into geoapi-3.1: implementation of GridEnvelope
interface.
     add fceec82  Fix missing "s" in "getOrderOptionsType()" for ISO 19115 compliance. https://github.com/opengeospatial/geoapi/issues/21
     add 59b5551  Fix spelling error in method name, but not in XML annotation since the spelling
exists in ISO specification. https://github.com/opengeospatial/geoapi/issues/43
     new 9426368  Merge branch 'geoapi-4.0' into geoapi-3.1 but without the change in Objective.getObjectiveOccurences()
method name. The old name is kept on GeoAPI 3.1 branch for compatibility reason.
     add 2492289  Rename "polarization" as "polarisation" in two method names for compliance
with latest ISO 19115 revision. https://github.com/opengeospatial/geoapi/issues/15
     add d6b8565  Renamed PolarizationOrientation as PolarisationOrientation for compliance
with latest ISO 19115-2 revision. Part of https://github.com/opengeospatial/geoapi/issues/23
     new f7fb545  Merge branch 'geoapi-4.0' into geoapi-3.1, taking only the renaming in annotations.
Renaming of methods or classes are not taken for compatibility reasons.
     add bf56b15  Renamed getCenterPoint() as getCentrePoint() for compliance with ISO 19115:2014.
     new 8164ff4  Merge branch 'geoapi-4.0' into geoapi-3.1, but replacing method renaming
by a comment about future evolution.

The 4 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 .../org/apache/sis/internal/book/GEOAPI.lst        |  2 +-
 .../resources/org/apache/sis/internal/book/OGC.lst |  2 +-
 ...de.java => MI_PolarisationOrientationCode.java} | 12 ++---
 .../apache/sis/metadata/PropertyInformation.java   |  3 +-
 .../metadata/iso/acquisition/DefaultObjective.java | 54 ++++++++++++++++------
 .../sis/metadata/iso/content/DefaultBand.java      | 20 ++++++++
 .../sis/metadata/iso/content/package-info.java     |  6 +--
 .../distribution/DefaultStandardOrderProcess.java  | 42 +++++++++++++----
 .../metadata/iso/spatial/DefaultGeorectified.java  |  8 ++++
 .../sis/test/xml/AnnotationConsistencyCheck.java   | 16 -------
 .../sis/coverage/grid/GridCoordinatesView.java     | 18 ++++----
 .../org/apache/sis/coverage/grid/GridExtent.java   | 23 ++++-----
 12 files changed, 133 insertions(+), 73 deletions(-)
 rename core/sis-metadata/src/main/java/org/apache/sis/internal/jaxb/code/{MI_PolarizationOrientationCode.java
=> MI_PolarisationOrientationCode.java} (88%)


Mime
View raw message