sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Desruisseaux (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SIS-438) Make SIS compatible with latest Java versions
Date Sun, 04 Nov 2018 20:21:00 GMT
Martin Desruisseaux created SIS-438:
---------------------------------------

             Summary: Make SIS compatible with latest Java versions
                 Key: SIS-438
                 URL: https://issues.apache.org/jira/browse/SIS-438
             Project: Spatial Information Systems
          Issue Type: Task
          Components: Utilities
            Reporter: Martin Desruisseaux
            Assignee: Martin Desruisseaux
             Fix For: 1.0


Apache SIS make two assumptions which are not valid anymore since Java 9:

 * It assumes that JavaDB is available in the Java installation directory. Note that this
is not true anymore even in Java 8 since latest updates (e.g. 1.8.0_191).
 * It assumes that JAXB is on the classpath. This is not true anymore since Java 9.

Actions to take:

* We should remove the search for JavaDB in {{org.apache.sis.internal.metadata.sql.Initializer.forJavaDB}}
lines 511 to 525.
* We need to make above method tolerant to {{ClassNotFoundException}}.
* We should add Derby dependency with runtime scope in {{sis-console}}.
* We need to add JAXB-API dependency in a Java 11 profile of root {{pom.xml}} file.




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message