sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Desruisseaux (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SIS-386) Deprecate DefaultEllipsoid.orthodromicDistance(…) method
Date Mon, 15 Jan 2018 11:17:00 GMT
Martin Desruisseaux created SIS-386:
---------------------------------------

             Summary: Deprecate DefaultEllipsoid.orthodromicDistance(…) method
                 Key: SIS-386
                 URL: https://issues.apache.org/jira/browse/SIS-386
             Project: Spatial Information Systems
          Issue Type: Bug
          Components: Referencing
    Affects Versions: 0.8, 0.7, 0.6, 0.5, 0.4
            Reporter: Martin Desruisseaux
             Fix For: 1.0


The {{DefaultEllipsoid.orthodromicDistance}} method has the following problems:

* Could have a better name.
* It does not converge in some situations.
* The wraparound over some non-convergence problems is itself erroneous.

Charles Karney kindly listed the problems [on the developer mailing list|https://lists.apache.org/thread.html/eee29fc53123e94b74c22737413b2572d3e4c9e4f111847fefb6a3af@%3Cdev.sis.apache.org%3E].
A possible action would be to deprecate {{orthodromicDistance}}, to be replaced by the same
{{GeodeticCalculator}} (or any other name) class than the one proposed for SIS-385.

*Historical note:* {{orthodromicDistance}} was defined in the {{DefaultEllipsoid}} class because
it made easy to override the method with code optimized for the spherical case. A future version
could also override the method with code for triaxial ellipsoid. But experience in the Geotk
project suggest that this method is almost never used, since {{GeodeticCalculator}} is used
instead.

As an alternative to deprecate {{DefaultEllipsoid.orthodromicDistance}}, we could keep it
(after renaming), fix the issues identified by Charles, and design {{GeodeticCalculator}}
as a class that use {{DefaultEllipsoid}} under the hood instead than re-implementing its own
algorithm.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message