sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Desruisseaux (JIRA)" <>
Subject [jira] [Commented] (SIS-177) Translate the developer guide to English
Date Thu, 28 Aug 2014 14:58:09 GMT


Martin Desruisseaux commented on SIS-177:

Thanks! I re-generated the Table Of Content and commited the new files on the staging web
site: http://localhost:8383/site/content/book/en/developer-guide.html

* Line 1331: yes, I was meaning its own section in the document. I added a link to that section.
* Line 1346: yes, "namespace" is the standard term.
* Line 1396: the idea behind "_for objects written with relatively few models_" was rather
"_for objects that do not occur very often in the document_". I will also update the French
sentence - I agree that it may be confusing.
* Line 1425: yes, I think that "_enclosed by_" is better.
* Line 1460: "_parent_" is okay from a _tree_ perspective, but would have a different meaning
from a _hierarchy_ perspective. Since XML mixes both, I'm not sure how we should interpret
"_parent_". Maybe "_enclosing_" is less ambiguous. But reading the original French again,
I feel that the whole paragraph was confusing. So I rewrote it and updated the English version
accordingly. The change was mostly to move around some sentence in order to form a numerated
list (the sentences stay about the same). The updated paragraph is [here|].
Please feel free to update or fix as you see fit.
* Line 1160: yes, "_dependencies chain_" is something that I have see too. I think it is good.
* Line 1501: agree, I added "_listed above_".
* Line 1738: "_safe operation_" sound good.
* Line 1742: I do not know how good is "_known to_" in standard English, but the translation
looks good to me.
* Line 1786: In this context, "Formatteur" would rather be "Formatter". I applied the replacement.
* Line 1810: I think that the original French was a bit confusing. I tried to reword it. Maybe
"_This is particularly useful for immutable classes used for creating unique instances independently
of local conventions_"?
* Line 1972: Yes I mean that one is large and complex and the other simpler. I think that
"cumbersome" is appropriate, but I replaced "less cumbersome" by "more lightweight", since
I have seen "lightweight" often used in similar context. It catch the idea that the later
is not only simpler for the developer, but also consume less memory (when the computer must
holds million of points, it may matter).
* Line 2121: I think the translation you did make a useful definition of terms. I think they
are good like that :-).
* Line 2175: The Oracle documentation uses "_inclusive_" and "_exclusive_" words, so I just
removed the trailing "_ly_".
* Yes, "_deprecated"_ is the word used in Oracle documentation. Thanks for replacing them.

I will add author and translator names somewhere in the page. Thanks again for all your work!

> Translate the developer guide to English
> ----------------------------------------
>                 Key: SIS-177
>                 URL:
>             Project: Spatial Information Systems
>          Issue Type: Task
>          Components: Documentation
>            Reporter: Martin Desruisseaux
>         Attachments: developer-guide-en.html, developer-guide-en.html, developer-guide2.html
> A developer guide (still incomplete) is available at
. However the guide has been written in French, in part because based on existing material
(e.g. some chapters written during thesis). This task is about translating the guide to English.

This message was sent by Atlassian JIRA

View raw message