sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin Desruisseaux (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SIS-61) Create a sis-build-helper module
Date Thu, 13 Sep 2012 10:08:07 GMT

    [ https://issues.apache.org/jira/browse/SIS-61?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13454783#comment-13454783
] 

Martin Desruisseaux commented on SIS-61:
----------------------------------------

The {{pom.xml}} file uses the {{$\{maven.version\}}} property, which is indeed a very useful
information when writing Maven plugins. But this property has been introduced only in Maven
3.0.4. Building the {{sis-build-helper}} module with an older Maven version cause a build
failure. The workaround is to specify the property explicitly on the command line, as in the
example below:

{noformat}
mvn install --define maven.version=3.0.3
{noformat}

However if many peoples are using older Maven versions, we would probably need to modify the
pom.xml for supporting them.

                
> Create a sis-build-helper module
> --------------------------------
>
>                 Key: SIS-61
>                 URL: https://issues.apache.org/jira/browse/SIS-61
>             Project: Spatial Information Systems
>          Issue Type: Task
>          Components: Build process
>            Reporter: Martin Desruisseaux
>            Assignee: Martin Desruisseaux
>             Fix For: 0.3-incubating
>
>
> Create a {{sis-build-helper}} module, not to be deployed, for:
> * Javadoc taglets
> * Optional PACK200 compression
> * LibreOffice/OpenOffice.org UNO
> * Resource compiler (internationalization)
> * Generating reports on supported map projections
> * Import EPSG database

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message