sis-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris A. Mattmann (JIRA)" <j...@apache.org>
Subject [jira] Commented: (SIS-26) Use of Java 1.6 Annotation in /sis-core/src/main/java/org/apache/sis/storage/GeoRSSData.java
Date Fri, 26 Nov 2010 15:55:13 GMT

    [ https://issues.apache.org/jira/browse/SIS-26?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12936041#action_12936041
] 

Chris A. Mattmann commented on SIS-26:
--------------------------------------

Thanks Fabian. We had a conversation a while back to accept JDK 1.6 as the target language
version for SIS. See here: 

http://www.mail-archive.com/sis-dev@incubator.apache.org/msg00073.html

I'll commit a patch shortly that updates the Java version in the parent POM to 1.6. 

> Use of Java 1.6 Annotation in /sis-core/src/main/java/org/apache/sis/storage/GeoRSSData.java
> --------------------------------------------------------------------------------------------
>
>                 Key: SIS-26
>                 URL: https://issues.apache.org/jira/browse/SIS-26
>             Project: Spatial Information Systems
>          Issue Type: Bug
>          Components: build process, storage
>         Environment: Eclipse 3.5.2, Sun JDK 1.6, SVN r1039302
>            Reporter: Fabian Christ
>
> The class /sis-core/src/main/java/org/apache/sis/storage/GeoRSSData.java contains the
following method
>   /* (non-Javadoc)
>    * @see org.apache.sis.storage.QuadTreeData#getLatLon()
>    */
>   @Override
>   public LatLon getLatLon() {
>     return this.latLon;
>   }
> The @Override annotation is not supported for interfaces by Java 1.5 and should be removed
or Java version in parent POM should be 1.6.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message