shale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig McClanahan" <craig...@apache.org>
Subject Re: Test failures in shale-usecases
Date Sat, 19 Aug 2006 06:04:17 GMT
On 8/18/06, Wendy Smoak <wsmoak@gmail.com> wrote:
>
> Anyone else?  Looks like we're getting the 2.3 Servlet API on the test
> classpath by way of HtmlUnit and Jelly.


That's strange ... it works for me on both Linux and Windows.

Craig


Test set: org.apache.shale.usecases.remote.ListCategoriesTestCase
>
> -------------------------------------------------------------------------------
> Tests run: 2, Failures: 0, Errors: 2, Skipped: 0, Time elapsed: 0.016 sec
> <<< FA
> ILURE!
> testExecute(org.apache.shale.usecases.remote.ListCategoriesTestCase)  Time
> elaps
> ed: 0 sec  <<< ERROR!
> java.lang.NoSuchMethodError:
> javax.servlet.http.HttpServletResponse.setCharacter
> Encoding(Ljava/lang/String;)V
>         at
> org.apache.shale.remote.ServletRemoteContext.setResponseEncoding(Serv
> letRemoteContext.java:261)
>         at org.apache.shale.remote.AbstractSelectItems.render
> (AbstractSelectItem
> s.java:200)
>         at org.apache.shale.remote.AbstractSelectItems.execute
> (AbstractSelectIte
> ms.java:130)
>         at org.apache.shale.remote.RemoteCommand.execute(
> RemoteCommand.java:160)
>
>         at
> org.apache.shale.usecases.remote.ListCategoriesTestCase.testExecute(L
> istCategoriesTestCase.java:132)
>
> --
> Wendy
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message