shale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Re: Test 1.0.3 Artifacts (Round 2)
Date Sat, 19 Aug 2006 06:51:09 GMT
On 8/18/06, Craig McClanahan <craigmcc@apache.org> wrote:

> WARNING:  If you have previously installed 1.0.3 artifacts from the earlier
> test build evaluation into your local repository, you will need to manually
> replace them, because these are not SNAPSHOT version numbers.

A non-SNAPSHOT version should be built exactly once if at all
possible.  Once it's in a repository, for all intents and purposes it
*is* released and should not be changed. [1]  Next time around let's
just evaluate the -SNAPSHOT version until it's ready to tag and
release.

> (2) Releaseable .tar.gz and .zip artifacts

Do we need both?  I think .zip is sufficient.

> KNOWN ISSUE:  The version number (1.0.3) is not included in the top level
> directory of the "war" distributions.  Need to figure out how to not do
> this, without disabling the generation of webapps that don't require version
> numbers in the context path.

I'll look at it tomorrow afternoon, but I suspect renaming the files
will be the easiest solution for 1.0.3.

> KNOWN ISSUE:  The "-dist" suffix on all of the above distibutions is
> somewhat useless.  We can rename the files, but it would be better to
> identify a way to make the assembly instructions do what we want in the
> first place.

The latest version of the assembly plugin has an option for this.  It
would require changing the assembly descriptors to the new format, and
I haven't been able to get it to do what I want.

Another issue: The portlet-api jar is included in WEB-INF/lib of
shale-blank.  I didn't check the others.  Also, LICENSE and NOTICE are
in WEB-INF/classes.  META-INF is probably more appropriate, as with
the jars.

[1]  (Yes, I know I just rebuilt Struts 1.3.5, but at least nothing
had changed in svn since the original.)

-- 
Wendy

Mime
View raw message