shale-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Wendy Smoak" <wsm...@gmail.com>
Subject Re: Previous system integration tests now failing?
Date Wed, 02 Aug 2006 04:59:15 GMT
On 8/1/06, Craig McClanahan <craigmcc@apache.org> wrote:
> Somewhere in the changes over the last couple of days, the old system
> integration tests on apps like shale-blank (mvn -Pitest install) have
> stopped working ... I get an exception from Cargo saying it is not able to
> create a deployable container.  Wendy, does this still work for you?

No problems here:

$ mvn -Pitest install
...
Running org.apache.shale.blank.systest.WelcomeTestCase
[INFO] container id: tomcat5x
[INFO] deployable: c:\svn\shale\framework\shale-apps\shale-blank/target/shale-bl
ank.war
[INFO] container home: c:\java\apache-tomcat-5.5.17
[INFO] container log: c:\svn\shale\framework\shale-apps\shale-blank/target/conta
iner.log
[INFO] container output: c:\svn\shale\framework\shale-apps\shale-blank/target/co
ntainer.output
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 29.515 sec

Results :
Tests run: 1, Failures: 0, Errors: 0, Skipped: 0

[INFO] [install:install]
[INFO] Installing c:\svn\shale\framework\shale-apps\shale-blank\target\shale-bla
nk.war to c:\java\m2-repository\org\apache\shale\shale-blank\1.0.3-SNAPSHOT\shal
e-blank-1.0.3-SNAPSHOT.war
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 49 seconds
[INFO] Finished at: Tue Aug 01 21:57:38 GMT-07:00 2006
[INFO] Final Memory: 8M/16M
[INFO] ------------------------------------------------------------------------

-- 
Wendy

Mime
View raw message