serf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko Čibej <br...@apache.org>
Subject Re: [patch] Py3 compat for create_certs.py
Date Sat, 28 Dec 2019 23:03:55 GMT
On 28.12.2019 17:49, James McCoy wrote:
> On Wed, Dec 04, 2019 at 10:34:00PM -0500, James McCoy wrote:
>> I use create_certs.py at build time in the Debian packaging to avoid
>> dealing with expired certs.  Since Debian is in the process of trying to
>> remove Python 2, I've updated the script to work with Python 3.
>>
>> It would also be useful if 1.4 were released, so I could switch to the
>> CMake build.
> These are both becoming more important issues.  As an alternative, is
> current trunk in decent enough shape to be used, even without an
> official release?
>
> I can also look into more of the Python3 issues (like SyntaxErrors in
> SConstruct) if there's a desire to release another 1.3.x version (or to
> carry the patches locally until a new release happens).


Sorry for not getting back to you sooner.

Trunk is, in my opinion, in decent enough shape to be used. But we
should still create  1.4, with full support for Python 3. I'll be happy
to apply any patches towards that goal.

-- Brane

Mime
View raw message