serf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yosi Zion <yosi...@eldan.co.il>
Subject please help - SharpSvn problem Question
Date Tue, 31 Jan 2017 10:13:46 GMT
Hello Bert,
How are you?

I am developing in C # with visual studio 2013,2015 and have a particular problem with SharpSvn
and I hope you can solve it for me.

Installs and downloads:
1.
I installed VisualSvnServer Version: 3.5.7 on a virtual server with the following settings:
Authentication tab - integrated windows authentication
Security tab - add permissions to my user (my user is administrator)
Certificate tab - change to my company certificate
Network tab - I use secure connection (https: //) with port 443
I add admin permission to the repository root

2. Client Side
TortoiseSVN 1.9.5, Build 27581-64 Bit
And AnkhSvn-2.6.12735

3. I downloaded the latest version of SharpSvn (SSvn-1.9005.3934.158-x64)

Problem Description:
When I'm trying to merge through the UI TortoiseSVN everything works fine and it perform the
merge and the commit to the repository/
When I try to do this through C# code with SharpSvn I get a message "Unable to connect to
a repository at URL 'https://MyServer.co.il/svn/noam2/Yosi/NorthwindTrunk2/Trunk'"
After call client.Merge(qa_work_copy, mergeFrom, revisionsRange, mergeArgs);
I think I tried everything:
I tried without Authentication of user and password
I tried Authentication of user and password via client.Authentication.ForceCredentials
I signed up for all the events of Authentication and some even not fired,
For example:
SharpSvn.Security.SvnSslServerTrustEventArgs
Authentication_SslClientCertificatePasswordHandlers

I even set the DefaultCredentials via System.Net.NetworkCredential(user, password) without
any success

Incidentally, I am successful to perform the Update action using an SharpSvn

I enclose you snippets of code I wrote to those who succeeded and those that failed
I do not know what to do about it and the more I will be happy if you can help me solve this
problem.

Some Screenshots:

[cid:image001.png@01D27BB6.E88FACC0]

[cid:image003.png@01D27BBB.782F6B00]


[cid:image005.png@01D27BBB.782F6B00]

Regards,
Yosi Zion | Senior developer
Department of Information Technologies | Eldan Group


Mime
View raw message