serf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bert Huijben (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SERF-142) Not possible to build Serf under MinGW!
Date Mon, 02 Nov 2015 22:30:27 GMT

    [ https://issues.apache.org/jira/browse/SERF-142?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14986177#comment-14986177
] 

Bert Huijben commented on SERF-142:
-----------------------------------

I think the problem here was that there was a Windows python install. I would guess a cygwin
python would normalize paths the cygwin way.

> Not possible to build Serf under MinGW!
> ---------------------------------------
>
>                 Key: SERF-142
>                 URL: https://issues.apache.org/jira/browse/SERF-142
>             Project: serf
>          Issue Type: Bug
>            Reporter: Serf Importer
>              Labels: Priority-Medium, Type-Defect
>
> Hi.
> I've tried to build Serf under Windows using MinGW toolchain. It's impossible - the build
fails with various errors. Why did you choose that SCons? I've tried to debug it and wasn't
very impressed by the code - it's very complex and tightly coupled. And by the way, APR, APU,
and OpenSSL build without problem under MinGW with their autotools. And all these libraries
are way more complex than serf.
> The problem is: as you know, MSYS terminal is launched from something like "chroot" -
i.e. / is in fact C:\MinGW\msys\1.0\ and you can't get out of it, you access C:\ as /c/. And
SCons gets mad about this fact - it tries to normalize all paths, so for example it changes
/usr/include/apr-1 to C:\usr\include\apr-1, and that's not correct, / isn't C:\! / is C:\MinGW\msys\1.0!
> Can you fix this problem in some way? I want to build Subversion using a free software
toolchain, without using msvc.
> Original issue reported by *vitalif@yourcmc.ru*



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message