serf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bert Huijben" <b...@qqmail.nl>
Subject RE: [serf-dev] [serf] r2489 committed - In preparation of serf 1.4.0, remove the get_remaining function from t...
Date Mon, 07 Sep 2015 10:33:18 GMT


> -----Original Message-----
> From: Greg Stein [mailto:gstein@gmail.com]
> Sent: maandag 7 september 2015 11:29
> To: Ivan Zhakov <ivan@visualsvn.com>
> Cc: dev@serf.apache.org
> Subject: Re: [serf-dev] [serf] r2489 committed - In preparation of serf 1.4.0,
> remove the get_remaining function from t...
> 
> How about: stop the debate? Remove it for 1.4.x (done), and bring it back
> for 1.5.x? ... The stuff I was doing on trunk for 2.x, I will move to a
> branch. Trunk will be 1.x.
> 
> There is no reason to keep get_remaining in 1.4. It sounds like we have
> further work to keep compatibility regardless. Some Windows linkage thing,
> that I don't entirely understand.
> 
> But let's move forward, rather than complain. There is a 1.4.x release to
> get out.

There are still two test errors on at least two major platforms:
Windows reports
1) test_ssl_missing_client_certificate: /srv/subversion/buildbot/slave/serf-x64-macosx/build/test/test_ssl.c:1815:
expected <120172> but was <120199>
2) test_ssl_server_cert_with_san_and_empty_cb: /srv/subversion/buildbot/slave/serf-x64-macosx/build/test/test_util.c:541:
expected <0> but was <120199>
(See https://ci.apache.org/builders/serf-x64-macosx/builds/6/steps/Test/logs/stdio)

And Mac reports with openssl 0.9.8
1) test_ssl_server_cert_with_san_and_empty_cb: /srv/subversion/buildbot/slave/serf-x64-macosx-default-openssl/build/test/test_util.c:541:
expected <0> but was <120199>
(See https://ci.apache.org/builders/serf-x64-macosx-default-openssl/builds/1/steps/Test/logs/stdio)

And with a more recent openssl:
1) test_ssl_server_cert_with_san_and_empty_cb: /srv/subversion/buildbot/slave/serf-x64-macosx-apr1_5/build/test/test_util.c:541:
expected <0> but was <120199>
2) test_ssl_renegotiate: /srv/subversion/buildbot/slave/serf-x64-macosx-apr1_5/build/test/test_ssl.c:1771:
expected <0> but was <120199>
(See https://ci.apache.org/builders/serf-x64-macosx-apr1.5/builds/5/steps/Test/logs/stdio)

I think I've had these errors on Windows for at least 3 months, probably longer.
(120199 is a generic serf test failure. The cases I looked at return this from the test http
server)


I have a hard time understanding these tests and I don't know what it would take to resolve
these.


	Bert


Mime
View raw message