ripple-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raymond Camden (JIRA)" <j...@apache.org>
Subject [jira] [Created] (RIPPLE-50) Ripple UI can default to an invalid platform
Date Fri, 10 Jan 2014 14:53:56 GMT
Raymond Camden created RIPPLE-50:
------------------------------------

             Summary: Ripple UI can default to an invalid platform
                 Key: RIPPLE-50
                 URL: https://issues.apache.org/jira/browse/RIPPLE-50
             Project: Apache Ripple
          Issue Type: Bug
            Reporter: Raymond Camden
            Priority: Minor


Imagine you have just created a new Cordova project and only added the iOS platform. When
you run "ripple emulate" (and don't specify a folder), Ripple will load and default its phone
selection to an Android device. Because you aren't using Android, you get an error:

Error: static() root path required
    at Function.static (/usr/local/lib/node_modules/ripple-emulator/node_modules/express/node_modules/connect/lib/middleware/static.js:49:20)
    at Object.handle 

If you switch to an iOS device, it works fine, and Ripple will remember as you relaunch it.


This is a rather easy bug to get around, but the error isn't very clear as to what is going
wrong - I think I was lucky to figure it out in the first place.

It would be nice if Ripple could recognize that you don't have Android and then try iOS as
a default. 

Maybe a second issue would be better handling of this particular error?



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message