ripple-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brent Lintner <brent.lint...@gmail.com>
Subject Re: Bug with picking non-android platform first
Date Thu, 09 Jan 2014 18:06:36 GMT
Hey Raymond,

That first error.. that (I assume) is because you need --path flag when
your CWD does not contain your web app?

Also, I'd agree that it would be ideal for Ripple to detect what OS it is
on, and select a device.. :-)


On Thu, Jan 2, 2014 at 10:32 AM, Raymond Camden <raymondcamden@gmail.com>wrote:

> Not sure if this is a bug or if it is expected.
>
> I've got a project with just iOS support. When I run ripple emulate, I get
> an error in the display:
>
> Error: static() root path required
>     at Function.static
>
> (/usr/local/lib/node_modules/ripple-emulator/node_modules/express/node_modules/connect/lib/middleware/static.js:49:20)
>     at Object.handle
>
> I noticed the device defaulted to Nexus 4. When I switched to an iOS
> device, it worked fine, and when I restarted Ripple it remembered my
> selection.
>
> So I guess the question is, should ripple have been smart enough to
> recognize I was doing iOS and defaulted to an iOS device? If so, I can file
> a bug report for it. (Although it is really easy to work around, I worry
> about what people may think if they don't know.)
>
>
> --
> ===========================================================================
> Raymond Camden, Adobe Developer Evangelist
>
> Email : raymondcamden@gmail.com
> Blog : www.raymondcamden.com
> Twitter: cfjedimaster
>



-- 
Brent Lintner

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message