ripple-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tomasz Trejderowski (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (RIPPLE-36) Ripple Emulator under Windows doesn't fire events
Date Fri, 20 Sep 2013 08:30:53 GMT

    [ https://issues.apache.org/jira/browse/RIPPLE-36?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13772871#comment-13772871
] 

Tomasz Trejderowski commented on RIPPLE-36:
-------------------------------------------

I have solved this only partially. Most events still doesn't fire.

The good question is, how to up Ripple's PhoneGap version?

Whenever I tried to use (code in HTML file pointing to {{cordova.js}}) PhoneGap version higher
than 2.0.0, Ripple was complying ("cheesburger") about missing function or wasn't working
at all. It is also noticed somewhere on Ripple project page or somehewere here in the issues,
that is is stopped on PhoneGap 2.0.0 and there are no certain plans, when this will be updated.

I'm not using PhoneGap 3.0.0 as long as PhoneGap Build doesn't support it, because I'm building
in the cloud, without local build environment. Version 2.9.0 is all fine with me, but I had
no idea, that upping Ripple version is possible and that easy (as assume from your comment),
without forking main repository and rebuilding entire Ripple itself.

So, how did you manage to up PhoneGap version behind Ripple?
                
> Ripple Emulator under Windows doesn't fire events
> -------------------------------------------------
>
>                 Key: RIPPLE-36
>                 URL: https://issues.apache.org/jira/browse/RIPPLE-36
>             Project: Apache Ripple
>          Issue Type: Bug
>         Environment: Windows 7 Home Edition, x86, Chrome browser (newest stable version),
Ripple Emulator extension for Chrome (newest stable version taken from Chrome Store).
>            Reporter: Tomasz Trejderowski
>
> Under Windows, Ripple Emulator doesn't fire events. Neither automatically (deviceready)
nor manually (using 'Event' pane). After selecting event and clicking button to fire it, Ripple
writes down info to console, that it fires particular event, but nothing happens -- application
does not react at all. When main init code is moved to 'deviceready' event, application fails
to start under Ripple Emulator, as this event isn't fired.
> Everything works just fine (both application startup and events' binding) under real
mobile device -- problem limited to Ripple Emulator only and therfore code seems to be fine.
> Details at Stack Overflow: http://stackoverflow.com/questions/17701869/ripple-emulator-doesnt-fire-events

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message